Beefree Loading Issues

Incident Report for Beefree

Resolved

The incident has been resolved.
Posted Sep 25, 2024 - 13:18 EDT

Monitoring

Our team deployed a fix and is monitoring the results.
Posted Sep 25, 2024 - 11:38 EDT

Investigating

We are aware of ongoing issues with Beefree App. Our team is working hard to investigate the issue.
Posted Sep 25, 2024 - 10:53 EDT
This incident affected: Web Portal.