Delays with Notification Emails

Incident Report for Beefree

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 10:10 EDT

Identified

We’re currently seeing delivery delays for some of the notification emails that Beefree sends, like password resets, user invites, test emails, and approval requests.

We’re actively investigating a potential issue with the main email provider for these notification messages. While we investigate, some messages may be sent from our backup email provider. Please check your spam folder if you’re waiting on an email from Beefree, or reach out to our support team for assistance.
Posted Jun 16, 2025 - 09:10 EDT
This incident affected: Web Portal.