INCIDENT - Beefree Web Portal

Incident Report for Beefree

Resolved

A brief increase in web traffic slowed down our response times. Customers may have experienced timeouts or reload pages while navigating the website and the Beefree application. The issue was brief, lasting about 3 minutes.
Posted Jul 16, 2025 - 00:00 EDT

Investigating

Outage in component 'Beefree Proxy'. The team is investigating.
Posted Jul 15, 2025 - 23:17 EDT
This incident affected: Web Portal.